Story Planner Support & Help Support Center

Contact Us

I have an older version of macOS. Can I run Story Planner on my Mac?

 Story Planner 5.0 and later versions are only available for macOS Catalina 10.15 and later. If you have an earlier version of macOS you won't be able to install Story Planner. Sorry.

We would have liked to offer version 5.0 for earlier versions of macOS, but unfortunately we had no choice but to perform this update only for Catalina. It was the only way to offer all the features of version 5.0 for macOS as well. We hope you understand.


Powered by HelpSite